Ноябрь 19, 2017, 04:51:04

Автор Тема: Как оживить дохлый Enter в 1С:Предприятии 7.7 под wine 1.2  (Прочитано 10141 раз)

1clinux

  • Administrator
  • Опытный пользователь
  • *****
  • Сообщений: 164
  • Карма: +7/-0
  • Fire come with me ...
    • Просмотр профиля
    • Вопросы и ответы по 1С на базе Linux
    • Email
Предлагаю своё решение проблемы с дохлым (мёртвым, по сути не работающим) Ентером (Enter) для 1С 7.7 под Wine 1.2...

Предлагаю воспользоваться FormEx.dll (всегда последняя версия всегда есть на http://www.dorex.ru/?download - спасибо им огромное!!!) или можите слить на форуме: http://1clinux.org/formex_t.zip.
Далее извлекаем файл "FormEx.dll", складываем в каталог C:\Program files\BIN\
Заходим в конфигуратор и:

1. в процедуру "ПриНачалеРаботыСистемы()" добавляем:
"
      Если ЗагрузитьВнешнююКомпоненту("FormEx.dll")=0 Тогда
            Предупреждение("Не удается загрузить внешнюю компоненту 1C++!",10);            
      КонецЕсли;      
"

2. создаём в глобальном модуле новую процедуру:
"
Процедура ПриНажатииКнопкиКлавиатуры(Конт, КодКл, Алт, Шифт, Контрл, Символ, ФСО)
   //Сообщить (КодКл);
   Если КодКл=13 Тогда
            Service = СоздатьОбъект("Сервис");
            Service.SendKeys("{TAB}");
       //КодКл=9;
   КонецЕсли;
КонецПроцедуры
"


Всё работает проверено на Wine 1.2 с моими библиотеками для решения проблем с запуском и панелью окно.


НАШЁЛ НЕДОСТАТОК: надо отбирать типы полей которые надо так обрабатывать а какие не надо щаз над этим работаю... думаю это уже не проблема!

Пожалуйста приводите ссылку на этот первоисточник 1clinux.org при размещении информации из данного сообщения!

C уважением LiOn.
« Последнее редактирование: Июль 26, 2010, 06:26:24 от 1clinux »

1clinux

  • Administrator
  • Опытный пользователь
  • *****
  • Сообщений: 164
  • Карма: +7/-0
  • Fire come with me ...
    • Просмотр профиля
    • Вопросы и ответы по 1С на базе Linux
    • Email
забыл сказать, когда я поместил dll в Каталог Информационной базы при инициализации стала вылетать ошибка "отсутствует интерфейс IInitDone", как только перенёс в рабочий bin и поменял правильно пути сразу стала иниться нормально!
вообще говорят не плохо бы сделать ещё segsvr32.exe на эту библиотеку...

Bedazzled

  • Новичок
  • *
  • Сообщений: 13
  • Карма: +0/-0
    • Просмотр профиля
    • Email
спасибо за инфу:)
кстати в паследней версии етерсовта это исправили:)

lion

  • Administrator
  • Супер пользователь
  • *****
  • Сообщений: 279
  • Карма: +2/-0
    • Просмотр профиля
    • SoftLine
    • Email
Это исправили в первых версия ЭтерСофта. НО это платное и закрытое решение!

На самом деле проблема в том, что АПИ винды позволяет выстраивать очередь из ХУКОВ. Винище это дело поддерживает плохо, тут и проблема.

Сильвестр17

  • Новичок
  • *
  • Сообщений: 1
  • Карма: +0/-0
    • Просмотр профиля
    • Проститутки москвы
спасибо за инфу:)
кстати в паследней версии етерсовта это исправили:)
Вот и весна вот и проститутки москвы уже давно на улице гуляют