1CLinux

Форум посвящённый вопросам работы 1С:Предприятия на ОС Linux => Вопросы установки 1С 7.7 на Linux => Тема начата: 1clinux от Июль 26, 2010, 06:03:04

Название: Как оживить дохлый Enter в 1С:Предприятии 7.7 под wine 1.2
Отправлено: 1clinux от Июль 26, 2010, 06:03:04
Предлагаю своё решение проблемы с дохлым (мёртвым, по сути не работающим) Ентером (Enter) для 1С 7.7 под Wine 1.2...

Предлагаю воспользоваться FormEx.dll (всегда последняя версия всегда есть на http://www.dorex.ru/?download - спасибо им огромное!!!) или можите слить на форуме: http://1clinux.org/formex_t.zip (http://1clinux.org/formex_t.zip).
Далее извлекаем файл "FormEx.dll", складываем в каталог C:\Program files\BIN\
Заходим в конфигуратор и:

1. в процедуру "ПриНачалеРаботыСистемы()" добавляем:
"
      Если ЗагрузитьВнешнююКомпоненту("FormEx.dll")=0 Тогда
            Предупреждение("Не удается загрузить внешнюю компоненту 1C++!",10);            
      КонецЕсли;      
"

2. создаём в глобальном модуле новую процедуру:
"
Процедура ПриНажатииКнопкиКлавиатуры(Конт, КодКл, Алт, Шифт, Контрл, Символ, ФСО)
   //Сообщить (КодКл);
   Если КодКл=13 Тогда
            Service = СоздатьОбъект("Сервис");
            Service.SendKeys("{TAB}");
       //КодКл=9;
   КонецЕсли;
КонецПроцедуры
"


Всё работает проверено на Wine 1.2 с моими библиотеками для решения проблем с запуском и панелью окно.


НАШЁЛ НЕДОСТАТОК: надо отбирать типы полей которые надо так обрабатывать а какие не надо щаз над этим работаю... думаю это уже не проблема!

Пожалуйста приводите ссылку на этот первоисточник 1clinux.org при размещении информации из данного сообщения!

C уважением LiOn.
Название: Re: Как оживить дохлый Enter в 1С:Предприятии 7.7 под wine 1.2
Отправлено: 1clinux от Июль 28, 2010, 04:14:11
забыл сказать, когда я поместил dll в Каталог Информационной базы при инициализации стала вылетать ошибка "отсутствует интерфейс IInitDone", как только перенёс в рабочий bin и поменял правильно пути сразу стала иниться нормально!
вообще говорят не плохо бы сделать ещё segsvr32.exe на эту библиотеку...
Название: Re: Как оживить дохлый Enter в 1С:Предприятии 7.7 под wine 1.2
Отправлено: Bedazzled от Август 18, 2012, 02:11:44
спасибо за инфу:)
кстати в паследней версии етерсовта это исправили:)
Название: Re: Как оживить дохлый Enter в 1С:Предприятии 7.7 под wine 1.2
Отправлено: lion от Октябрь 15, 2012, 12:20:48
Это исправили в первых версия ЭтерСофта. НО это платное и закрытое решение!

На самом деле проблема в том, что АПИ винды позволяет выстраивать очередь из ХУКОВ. Винище это дело поддерживает плохо, тут и проблема.
Название: Re: Как оживить дохлый Enter в 1С:Предприятии 7.7 под wine 1.2
Отправлено: Сильвестр17 от Март 12, 2013, 08:51:33
спасибо за инфу:)
кстати в паследней версии етерсовта это исправили:)