Декабрь 17, 2018, 02:15:43

Просмотр сообщений

В этом разделе можно просмотреть все сообщения, сделанные этим пользователем.

Сообщения - emfiro

Страницы: [1]
1
Доброго времени суток. Возможно кто-то уже решил данную проблему. На debian 6.0.6 x86_64 был установлен сервер 1С:предприятие i386. Произведена публикация базы с помощью :

/opt/1C/v8.2/i386/webinst -apache22 -wsdir 1с -dir '/var/www/1c/' -connStr 'Srvr="deb-test";Ref="1c";' -confPath /etc/apache2/httpd.conf

Публикация прошла успешно. Содержимое файла httpd.conf

LoadModule _1cws_module "/opt/1C/v8.2/i386/wsap22.so"

# 1c publication
Alias "/1c" "/var/www/1c//"
<Directory "/var/www/1c//">
    AllowOverride All
    Options None
    Order allow,deny
    Allow from all
    SetHandler 1c-application
    ManagedApplicationDescriptor "/var/www/1c//default.vrd"
</Directory>

и содержимое default.vrd

<?xml version="1.0" encoding="UTF-8"?>
<point xmlns="http://v8.1c.ru/8.2/virtual-resource-system"
                xmlns:xs="http://www.w3.org/2001/XMLSchema"
                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                base="/1c"
                ib="Srvr=&quot;deb-test&quot;;Ref=&quot;1c&quot;;"/>


После публикации не стартует апач,


apache2: Syntax error on line 207 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/httpd.conf:
Cannot load /opt/1C/v8.2/i386/wsap22.so into server: /opt/1C/v8.2/i386/wsap22.so: wrong  ELF class: ELFCLASS32


Т.е. ему не нравится вот это

LoadModule _1cws_module "/opt/1C/v8.2/i386/wsap22.so"

Гугл не выручил меня вообще никак.

Почему у апача не получается загрузить данный модуль?

 Спасибо.

P.S. На Ubuntu 10.04.4 x86_64 тоже самое

Страницы: [1]