Сентябрь 20, 2018, 09:57:58

Просмотр сообщений

В этом разделе можно просмотреть все сообщения, сделанные этим пользователем.

Сообщения - acsbaks

Страницы: [1]
1
Ахренеть.... Если бухгалтерию, как пишут перестанут поддерживать! Какой же массовый переход на 8 буит!!

2
Enter - это единственное, что преджставляет неудобства, т.к. часто имею дело с разными базами, и в каждую прописывать это если честно влом... Другого выхода нету? Не в курсе??

3
Странно, но именно у них на сайте я видел, что бля регистрации компонентов нужно выполнить команду:
ieinstall
Что тут установиться я думаю ответ однозначный!!! А за ссылочку - спасибо: попробую!

4
Нигде еще не видел, и решил написать полную инструкцию по установке 1С 7.7 на свободном Wine.
Имеем Ubuntu 10.04. Поэтому в дальнейшем буду описывать все, как я делал в ней!
Начинаем с добавление apt ссылки: Система - Администрирование - Источники Приложений.
Вкладка - Другое По. Добавляем - ppa:ubuntu-wine/ppa
Ссылки для другим систем можно посмотреть на сайте winehq.org
Заходим в терминал
sudo aptitude update
sudo aptitude install wine1.3
winetricks dcom98 //нужна ДКОМ для запуска 1С, и зачем самому скачивать лезть и много операций делать, если уже для нас это упростили
Копируем из винды MSVCRT40.DLL в папку - /home/usr/.wine/drive_c/windows/system/
winetricks MFC42.DLL
//Установим шрифты
winetricks corefonts
winetricks tahoma
winetricks lucida
//если каких шрифтов не буит - можно взять из установленной где-нить винды
Устанавливаем 1С 7.7 (тут задерживаться не буду :)) //У меня ярлычок создался на раб. столе сам, с этим заморочек нету
Запускаем 1С базу конфигуратор и Убираем галочку из меню Окна - Панель Окон - Показать (Это нужно сделать раз для каждой базы и для каждого вида запуска - будь то конфигуратор, предприятие,....)
Чтобы не было проблем с кодировкой - либо заходим в БД, меню администрирование - кодовая страница таблиц ИБ и меняем на +Текущая системная установка и ждем.....
Иногда это не совсем удобно, если бд используют виндовые машины, тогда создаем либо в папке с базой, либо в каталоге BIN 1C пустой файлик OrdNoChk.prm

Локальная версия должна заработать!!
Но это нам не интересно, нужно в базу заходить по сети.
Качаем etercifts c сайта Etersoft. Он свободный и не требует оплаты. Устанавливаем (инструкции по нему - на етерсофте).
После его установки потребуеться перезагрузка.
Открываем fstab и добавляем строки для монтирования нужных сетевых ресурсов
//server1c/BaseBuh /home/usr/BaseBuh cifs rw,user,username=WORKGROUP\имяпользователя,password=пароль,iocharset=utf8,noperm,forcemand,direct 0 0
sudo mount /home/usr/BaseBuh
Теперь папка с базой у нас смонтирована, и мы можем добавить базу.

Это же вновь не то, что хотелось, ведь база у нас на SQL сервере.
winetricks mdac25
winetricks mdac28
winecfg: sqlsrv32.dll - сторонняя.
возможно мдак25 и не надо было сначала устанавливать, но так я делал.
Проверяем:
wine regedit
"HKLM\Software\ODBC\ODBCINST.INI" - Должна быть папочка с названиес "SQL Server" если нету - копируем из винды и проверяем путь: строковый параметр - Driver.
Вуаля, заработала связка 1С+SQL.
Но могут быть проблемы с нахождением сервера, в этом случае заходим в конфигуратор - Администирование - Параметры базы данных SQL и адрес сервера меняем с имени на его Ай-Пи адрес.

1С мы запустили но мне, как разработчику плохо живеться без OpenConf.
Качаем последний OpenConf.
Перед установкой OpenConf поставить MS Visual Basic 6 runtime (нужен для регистрации c:/Program Files/1Cv77/BIN/config/system/svcsvc.dll)
winetricks vb6run
Поставить ie нужен для регистрации wsc компонентов)
winetricks ie6
Зарегистрировать все WSC компоненты из каталога c:/Program Files/1Cv77/BIN/config/system
wine regsvr32 /i:CommonServices.wsc C:/windows/system32/scrobj.dll и т.д.
Компонент OpenConf.RegistryIniFile.wsc надо регистрировать в последнюю очередь!

Эта статья была чуть модифицирована, ориганал - http://kb.etersoft.ru/Установка_OpenConf_для_1с_7.7_в_Wine

Осталась одна проблема с мертвым Enter-ом. В журнале документов либо в форме списка справочников он не работает!

Предлагаю воспользоваться FormEx.dll (всегда последняя версия всегда есть на http://www.dorex.ru/?download - спасибо им огромное!!!) или можите слить на форуме: http://1clinux.org/formex_t.zip.
Далее извлекаем файл "FormEx.dll", складываем в каталог C:\Program files\BIN\
Заходим в конфигуратор и:

1. в процедуру "ПриНачалеРаботыСистемы()" добавляем:
"
      Если ЗагрузитьВнешнююКомпоненту("FormEx.dll")=0 Тогда
            Предупреждение("Не удается загрузить внешнюю компоненту 1C++!",10);           
      КонецЕсли;     
"

2. создаём в глобальном модуле новую процедуру:
"
Процедура ПриНажатииКнопкиКлавиатуры(Конт, КодКл, Алт, Шифт, Контрл, Символ, ФСО)
   //Сообщить (КодКл);
   Если КодКл=13 Тогда
            Service = СоздатьОбъект("Сервис");
            Service.SendKeys("{TAB}");
       //КодКл=9;
   КонецЕсли;
КонецПроцедуры
"

За эту статью спасибо - 1clinux; http://1clinux.org/index.php?topic=188.0

Вот в принципе и все :) имеем полностью рабочую 1С, запущенную на свободном вайне!
P.S. Ubuntu начал пользоваться 2 мес. назад. Если что - не пинайте. Может кому-нить эта статья пригодиться!
PP.S. Когда пытался запустить игрушки баловался с winetricks (d3dx9, directx9 и т.д.). И после этого панель окон стала нормально отображаться. 1С перестала вызывать ошибку и нормально работает (либо это связано с обновлением вайна, ктр я сделал незадолго до этого). В настройках Wine для 1С убрана лишь галочка - "разрешить менеджеру окон декорировать окна".

Страницы: [1]