Апрель 25, 2018, 07:55:32

Автор Тема: Настройка веб-публикации 1с сервера 8.2.15.289  (Прочитано 11254 раз)

deev

  • Новичок
  • *
  • Сообщений: 4
  • Карма: +0/-0
    • Просмотр профиля
    • WordPress и Master-It
    • Email
Доброго времени суток! Пробую запустить веб сервер хамрр 1.7.4 с опубликованной 1с - версии 8.2.15.289.rpm, консоль возвращает ошибку:
/opt/lampp/lampp restart
Stopping XAMPP for Linux 1.7.4...
XAMPP: Stopping Apache with SSL...
httpd: Syntax error on line 511 of /opt/lampp/etc/httpd.conf: Syntax error on line 9 of /opt/lampp/etc/extra/httpd-xampp.conf: Cannot load /opt/1C/v8.2/i386/wsap22.so into server: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6) -уже не знаю, что и делать...
версия ОС LinuxWizard  Server release 2.0 (Final)

amaranth

  • Новичок
  • *
  • Сообщений: 2
  • Карма: +0/-0
    • Просмотр профиля
Обновите ваш GCC:
sudo add-apt-repository ppa:ubuntu-toolchain-r/testДалее:
sudo apt-get install gcc-4.6
sudo apt-get install g++-4.6
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 20
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.6 20
sudo update-alternatives --config gcc

deev

  • Новичок
  • *
  • Сообщений: 4
  • Карма: +0/-0
    • Просмотр профиля
    • WordPress и Master-It
    • Email
Теоретически да! Но практически, у меня стоит лицензионный сервер LinuxWizard (CentOS)  и в еге репозиториях я не обнаружил ни gcc-4.6, ни g++-4.6 , и единственно-правильным выходом в данном случае является использование сервиса httpd, т.е. я сконфигурировал /etc/httpd/conf/httpd.conf на работу с 1с и все нормально заработало, подробную инструкцию я написал здесь http://www.alt.h12.ru/notebook.php